Topic

By: f1bash
Posts: 9
Joined: 16/08/09

MX5 Car will not start after lay up and new battery , nothing no dash lights engine does not turn nothing

I have just bought a 1991 MK1 MX-5 1600cc manual E/W , E/L , P/S , A/C , the previous owner drove the car into his garage in January as he works abroad it was driving and running OK , when he came home a few weeks ago he tried to start it but flat battery . Charged battery , he did say there was a flash on putting leads back on . Went to start car nothing , no dash lights , nothing not even a click from starter when ignition key is turned . Got a so called mechanic in he said he needed new battery so he bought one , after fitting new battery car still the same nothing on dash , turn ignition key nothing . Mechanic then said could be a broken wire and the car needed to go on diagnostics to sort it out . I cannot believe anything serious can happen just for being stood a few months . Any ideas f1bash

Replies

  1. Re: MX5 Car will not start after lay up and new battery , nothing no dash lights engine does not turn nothing

    I've swaped out the battery on my car (Identical to yours) many times, and never seen a flash... sound like the battery was put in the wrong way around! Sad

    That is a nice and simple way to fry the ECU...
    Posted: Aug 17 2009 By: bloodline   Posts: 469
  2. Re: MX5 Car will not start after lay up and new battery , nothing no dash lights engine does not turn nothing

    I would have to agree with Bloodline, there should not be a flash or spark when you connect the battery.
    It is very possable the ECU has been spiked(fried).
    The other possability that there was something turned on like the heater ,lights, etc when the battery was connected and it has blown a fuse then.
    Posted: Aug 17 2009 By: Nearly too late   Posts: 20
  3. Re: MX5 Car will not start after lay up and new battery , nothing no dash lights engine does not turn nothing

    The dark current (I.e. Everything switched off on an mx5) is so small, that you don't see anything when you connect the battery (unlike my mothers mercades... Another story).

    If there were some electrical systems switched on (fan, radio, lights etc) then it is possible that the current surge took out a fuse or two... If you are lucky...
    Posted: Aug 17 2009 By: bloodline   Posts: 469
  4. Re: MX5 Car will not start after lay up and new battery , nothing no dash lights engine does not turn nothing

    Sorted it was the main fuse , only problem once i had ignition lights was to find out how to reset after market Immobiliser and alarm , but after pushing buttons got the engine and remote locking working . It runs perfect has perfect oil pressure , no noices apart from the problem below

    MX5 1991 1600cc Manual . Only problem is it starts first touch of the key but fist revs drop then pick up then it idles OK but if you rev it up on release the revs drop right down until the engine stumbles then it picks its self up and idles correctly at about 850-875 rpm . There is no hunting or revving up and down at idle its just when you rev it up or hold it at Revs then let go of the throttle it drops to nearly zero revs stumbles then picks its self up and ticks over OK . Anyone any suggestions please . Tony

    Posted: Aug 17 2009 By: f1bash   Posts: 9
  5. Re: MX5 Car will not start after lay up and new battery , nothing no dash lights engine does not turn nothing

    Does it have problems getting up to speed? Is it slow off the mark at traffic lights, stop signs etc.? If so I suggest it might be the Woodruff key. I had similar with my 1991 model.
    Posted: Aug 20 2009 By: need4speed   Posts: 26
  6. Re: MX5 Car will not start after lay up and new battery , nothing no dash lights engine does not turn nothing

    I did what a member suggested and cleaned the throttle body out and reset the idle , the car is running perfect now in fact you can hardly hear it running . Only thing is upon getting it up in the air i have found it needs welding so don't really know what to do with it yet . I have a Mint 1993 MX5 MK1 which took me months to find the best car i could as its my last Toy . I was hoping to test this car and use it as an every day runabout ( my silver one has never been out in the rain since imported in 2000 ) My son also runs a MX5 1992 also in silver . The bought car has had loads spent on it and is a UK model not an export one and has Central locking P/S , E/W , Chrome boot slats , Excellent tyres , new calipers ,Pads , Discs , front shockers & springs , New Exhaust , Discs , Clutch 40000 miles ago , steering rack . Body work poor but every thing works and if welded would make a cheap MX5 runabout , but my welding days are over so may just sell on or keep for spares for our own two cars. Tony

    Posted: Aug 21 2009 By: f1bash   Posts: 9
  7. Re: MX5 Car will not start after lay up and new battery , nothing no dash lights engine does not turn nothing

    Hello,
    Can you tell me what the Woodruff key does ??? and where it is ??
    I've got a problem with pickup on mine and it might be related.
    Thanks.
    Posted: Aug 21 2009 By: Jinxy1562   Posts: 8
  8. Re: MX5 Car will not start after lay up and new battery , nothing no dash lights engine does not turn nothing

    Are you talking about the wood-ruff key holding the Crankshaft Pulley on . If so i think what happens is it can come loose at the bolt and wear the key on the very early engine's the one with lots of slots around the pulley , if this happens if i am correct what you get is wrong timing as the pulley is not in the correct position . I do not think it has any thing to do with your problem unless your pulley has moved and some one else has timed up the car with it in the wrong position . Has the car been running OK up to now , or have you or could any one else have timed the car . Put a Pencil or something soft down No1 plug hole and turn the engine slowly until it gets to TDC then check the timing marks on the pulley are on TDC . If not pulley has moved . Tony
    Posted: Aug 21 2009 By: f1bash   Posts: 9